The Gypsy and Imagine updates that are coming through Cricut Sync are corrupt and will make either machine not work properly. If you already installed them and are having problems just be patient Provocraft knows about this of course and the next update released will fix everything.

I know it’s hard to not have your toys to play with but don’t try to rest them it could permanently¬†damage the unit.

I will post again when it is safe to download the updates so keep checking back.

Advertisements